Cisco 887- configure FastEthernet port as WAN

Below is successfully working configuration to configure Cisco 887 router interface as WAN port, remember that you cannot make these FastEthernet interfaces as L3 (no switchport) and you cannot assign IP address to these interfaces, so instead create SVI as we did below.

  • Configure inside interface as “ip nat inside” and outside interface as “ip nat outside”.
  • NAT rule should be “ip nat inside source” instead of “ip nat source”, the difference is “ip nat inside source” is used for physical interface and “ip nat source” is used for virtual interface.

cisco-route-887-wan-configuration

ip dhcp excluded-address 192.168.200.1 192.168.200.20

ip dhcp pool ROFFICEDHCP
network 192.168.200.0 255.255.255.0
default-router 192.168.200.1
dns-server 8.8.8.8 8.8.4.4
lease 0 2

interface FastEthernet0
description CONNECTED TO WAN
switchport access vlan 100
no ip address
spanning-tree portfast

interface FastEthernet1
switchport access vlan 200
no ip address
spanning-tree portfast

interface FastEthernet2
switchport access vlan 200
no ip address
spanning-tree portfast

interface FastEthernet3
switchport access vlan 200
no ip address
spanning-tree portfast

interface Vlan1
no ip address
shutdown

interface Vlan200
description LAN
ip address 192.168.200.1 255.255.255.0
ip nat inside
ip virtual-reassembly in

All in One WordPress Hosting
HostGator $2.75 per month
HostGator
24/7/365 Technical Support, Free Site Building Tools, 4500 Website Templates, Free Shopping Cart Software, Ideal for WordPress, 45 Day Money Back Guarantee
Starts at 30$ per month
All in One WordPress Hosting
WordPress
High optimized WordPress hosting, secure firewall, HTTPS, Backup, hack-fix guarantee and many others at 30$ per month

interface Vlan100
description WAN
ip address 192.168.100.1 255.255.255.0
ip nat outside
ip virtual-reassembly in

ip default-gateway 192.168.100.254

ip nat inside source list 100 interface Vlan100 overload
access-list 100 permit ip 192.168.200.0 0.0.0.255 any

ip route 0.0.0.0 0.0.0.0 192.168.100.254