VLAN trunk between Cisco and HP switch

1109

hp-cisco-switch-trunkIn Cisco switching terms, we call it as trunk, however in HP switching terms, this is tagged.

On Cisco switch,

!Create VLAN 2 and SVI for finance dept. clients to use as their gateway IP
Cisco(config)#vlan 2
Cisco(config-vlan)#name “finance-users”
Cisco(config-vlan)#exit
Cisco(config)#interface vlan 2
Cisco(config-vlan)#ip address 192.168.2.1 255.255.255.0
Cisco(config-vlan)#no shut
Cisco(config-vlan)#exit

!Create VLAN 3 and SVI for hr dept. clients to use as their gateway IP
Cisco(config-vlan)#vlan 3
Cisco(config-vlan)#name “hr-users”
Cisco(config-vlan)#exit
Cisco(config)#interface vlan 3
Cisco(config-vlan)#ip address 192.168.3.1 255.255.255.0
Cisco(config-vlan)#no shut
Cisco(config-vlan)#exit

Cisco(config)#interface GigabitEthernet 0/25
Cisco(config-if)#description “Connected to HP switch – floor 1”
Cisco(config-if)#switchport trunk encapsulation dot1q
Cisco(config-if)#switchport trunk allowed vlan 2
Cisco(config-if)#switchport mode trunk

Cisco(config)#interface GigabitEthernet 0/26
Cisco(config-if)#description “Connected to HP switch – floor 2”
Cisco(config-if)#switchport trunk encapsulation dot1q
Cisco(config-if)#switchport trunk allowed vlan 3
Cisco(config-if)#switchport mode trunk

On HP01 switch,

HP01(config)#vlan 2
HP01(config)#name “finance-users”
HP01(config)#untagged 1-46
HP01(config)#tagged 47

On HP02 switch,

HP02(config)#vlan 3
HP02(config)#name “hr-users”
HP02(config)#untagged 1-46
HP02(config)#tagged 47



Related Articles & Comments

Thank you for visiting us. To continue receiving updates, please Subscribe to our Social Media Channels.

Google+
FACEBOOK
RSS
YOUTUBE
Menu Title
%d bloggers like this: